Mandar Kothavade

Unlicensed
  • Content count

    1
  • Joined

  • Last visited

About Mandar Kothavade

  • Rank
    Learner License
  1. Dear sir, I have maruti suzuki omni mpfi model of 2006. I have a problem in temperature gauge of this car and problem started about an year ago here is detailed description of problem: Temperature gauge (meter) of the car goes at high after turning on the engine for some time usually 5-10 min. (idle or driving ). here what happens exactly when i turn on the car when its completely cold like parking of overnight the needle comes smoothly slightly above cold mark & well below from center of the gauge. As i start the engine it goes up smoothly indicating the rise in temperature and reaches high crosses High position too when i run the engine continuously for more than 15-20 min. As everything in gauge happens smoothly (no shaky and sudden changes) seems its not a problem of gauge. But also the engine seems to be in operating temperature range no sign of overheating, never had any issues even in long drives too. This problem started about an year ago and still i am finding its cause. here is what i have done 1) flushed the radiator and filled in new coolant with 40:60 ratio of coolant:distilled water. then still the problem continued 2) checked thermostat valve it is operating properly. verified by checking temperature of water inside the radiator by keeping cap open before starting the engine from cold state. after some time water gets circulated and hot water comes in radiator which is sign of proper working thermostat valve and water pump. And in my vehicle cooling fan is by default rotating by engine power there is no on off provision for cooling fan. So thermostat valve, water pump and cooling fan all seems fine. still problem continues 3) replaced temperature sensor (called temperature tee by shopkeeper). It is the single wired sensor and it connects to grounds with the its threads. Then still the same problem continued. while changing the temperature tee, I found that I think there is one more temperature sensor with 3 terminals but its connector is equipped with only two wires and its in pristine state. But its sure that the temperature gauge works on temperature tee which i replaced previously (verified by disconnecting the wire during on position and gauge needle drops ). Now I am confused for what purpose this extra temperature sensor is there which is located just besides this single terminal temperature sensor. Again i checked for variation in resistances of both temperature sensors using digital multi meter. I have recorded three readings at cold state, after running engine for 2 min. then running for 10 min. cold state(ambient temp. around 24 Celcious) 2 min. idling 10 min. idling 2 wire temperature sensor : 1270 ohms 850 ohms 290 ohms (measured resistance between two terminals) single wire temperature sensor : 450 ohms 180 ohms 130 ohms (measured resistance between single terminal and body as a ground ) The readings of 2 wire temperature sensor are in alignment of most of the common temperature sensors specification which i have searched on internet and in youtube videos. But i did not found any specification for single terminal temperature sensor (doesnt matter as i already replaced it) and even old sensor also gives about same readings. Again I came to conclusion that meter is damaged. But i shown this problem to 3 different mechanics but nobody is able to track down what exactly problem is. And everybody says meter seems working fine because as soon as i disconnect single wired temperature sensor it comes down to cold mark and everything goes smooth. I showed in maruti authorized service center and those people are like insane said that they will first replace radiator, then sensors, thermostat valve, and if still problem continues they will replace temperature meter. its seems like very costly and that is too without proper diagnosis. besides everything car works fine with no sign of overheating. But i want this meter corrected. sometimes i think of buying new meter but its costly like I need to change entire speedometer panel as it doesnt comes as separate unit. And I am worried about what if problem still continued? Please somebody help me to track down the problem. As I need that damm.. temperature meter working because I always feels like something wrong with my car every time i drive it. Thank You Mandar Kothavade mandar.kothavade@gmail.com