Search the Community

Showing results for tags 'DDAS'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Introductions
  • Car & Bike Talk
    • Indian Cars
    • Indian Bikes
    • Test Drives & Reviews
    • International Scene
    • Exotics & Imports In India
    • Commercial Vehicles Scene in India
    • Vintage and Classics in India
  • Techies Garage
    • AAA - Ask Autocar Anything
    • Performance
    • Accessories & In-Car Entertainment
    • The Workshop
  • Motorsport
    • Indian Motorsport
    • International Motorsport
  • Miscellaneous
    • Opposite Lock
    • Auto Trader
    • Travelogues & Travel Queries

Found 1 result

  1. I need some information on this specific technical issue. Seek your help and comments. Does the DDIS (Digital Drive Information System) / DDAS (Digital Drive Assist System) has it's own in-built, rechargeable, button battery/batteries ? This data is needed by me as my Xylo E8's DDAS is behaving funny now, for the last one week or so. The car's batter is perfect. No issues with that. No starting trouble and no other electrical issues. The Date/Time on the DDAS is getting reset whenever the engine is switched off. It is asking me to key in the date/time every time I start the engine. All the other parameters are OK. The fuel indicator, the mileage-to-empty, gear indicator, inside and outside temperature etc., are shown perfectly. Becuase these parameters are calculated on-the-fly whereas the date/time are `carried over' from the memory. So, I feel that this DDAS must have a rechargeable, button type of battery (one or more) built-in. What's your say on this ? Has any ACI'an faced similar problem/glitch ? And, how it was resolved ? I did not talk to any M&M Dealer or Service Personnel, so far. Anyway, I have to take my Xylo for it's annual servicing this month-end (max by mid-Jan'13). By then, I should have sufficient info/data on this. (oops ! there's a typo error in the title. Please read " it'w " as " it's ". Sorry for that)