Search the Community

Showing results for tags 'heating'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Introductions
  • Car & Bike Talk
    • Indian Cars
    • Indian Bikes
    • Test Drives & Reviews
    • International Scene
    • Exotics & Imports In India
    • Commercial Vehicles Scene in India
    • Vintage and Classics in India
  • Techies Garage
    • AAA - Ask Autocar Anything
    • Performance
    • Accessories & In-Car Entertainment
    • The Workshop
  • Motorsport
    • Indian Motorsport
    • International Motorsport
  • Miscellaneous
    • Opposite Lock
    • Auto Trader
    • Travelogues & Travel Queries

Found 1 result

  1. Hi, I have a WagonR that I bought in 2009(around Novemeber) . I am facing a rather confusing heating problem with the car. It typically happens when the car a/c is on. Over the past two months I have got the radiator changed,coolant replaced several times but the problem still persists. Finally after observing the heating on a number of occasions, I have observed the following: 1) Never happens over short distances (2-5KM) 2) Typically occurs when the a/c is on. 3) It is now occurring after a long drive (20-30KM) on the highway after which the car needs to be slowed down in traffic. 4) The last time it heated up, I checked the water in the radiator and the bottle , it was near full. I showed it to a mechanic , he found no problem with it at first look. The fan auto cut was working fine as per him. Any idea what the issue might be?