Recommended Posts

Every time I start the car, put it in gear and move, I hear a knocking sound. It stops almost immediately, in 20 seconds. This happens mostly in reverse and especially after the car hasn't been used for more than 6-7 hours. Any idea what this could be? Thanks in advance.

Share this post


Link to post
Share on other sites

Does it come when you put the reverse gear? If so then do not put reverse gear while clutch is not pressed properly. Release the clutch and re push it and then put the reverse gear.

Share this post


Link to post
Share on other sites

It happens not on not pressing the clutch properly but on releasing the clutch after the car has been put in gear. And no, it doesn't necessarily happen only in reverse; it also happens in the first gear.

Share this post


Link to post
Share on other sites

If it a SUV then the gear box makes the noise because of the oil which has not reached the gear and bearings in the gearbox , so once you start engine the oil starts to reach which takes around 20 to 25 soconds .... So don't worry .

Share this post


Link to post
Share on other sites

How many kms has the car run? If its more than 60k kms then check for worn clutch, cold clutch will be grip the flywheel well at start but after some frictional heating it may be make some noise. Also check the fuel injectors they might be clogged and might require cleaning similarly for throttle body. Also check the air filter and see if anything is stuck in the piping.

There can be many different things but check your silencer and exhaust because if there is a hole due to rusting then due to different back pressure engine might need to work harder.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now