brijesh41183

svs light problem in swift vdi

Recommended Posts

 Hi,

 i have swift vdi  and clocked 33700 km and i have problem in my car . when  i put the key in ignition and started it in ON mode the SVS light blows does not go off after few minutes  it blows on only but when i start  the car SVS light goes off . is there problem in my car and ask  to MASS  he tell to about battery problem please tell me what i do

Share this post


Link to post
Share on other sites

 I went to MASS it is battery problem

so i got the quote of

EXIDE din 74 ah 7800 rs 2+2warranty

AMARON din 74 ah7400 rs 2+2warranty

 between this two which company brand should go or any other car battery company please tell me fast  it urgent.

No bold posts. Also, punctuate properly. What is this i, din, bad grammar, etc. MODS

sgiitk2011-02-17 05:03:13

Share this post


Link to post
Share on other sites

hi,

If battery is weak can i run the car in that condition or it will create a problem in ECU or any other parts in the engine because i think that i can use that battery for  6 month and i will change please reply.

Share this post


Link to post
Share on other sites

Two things:

You can get the replacement battery far cheaper outside. No need to go to a mass.

For the past decade in our family we are only buying Amaron once the OE gives up the ghost.

No real harm in running with a battery on the death bed. It is  pain and best avoided.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now