brijesh41183

svs light problem in swift vdi

Recommended Posts

 Hi,

 i have swift vdi  and clocked 33700 km and i have problem in my car . when  i put the key in ignition and started it in ON mode the SVS light blows does not go off after few minutes  it blows on only but when i start  the car SVS light goes off . is there problem in my car and ask  to MASS  he tell to about battery problem please tell me what i do

Share this post


Link to post
Share on other sites

 I went to MASS it is battery problem

so i got the quote of

EXIDE din 74 ah 7800 rs 2+2warranty

AMARON din 74 ah7400 rs 2+2warranty

 between this two which company brand should go or any other car battery company please tell me fast  it urgent.

No bold posts. Also, punctuate properly. What is this i, din, bad grammar, etc. MODS

sgiitk2011-02-17 05:03:13

Share this post


Link to post
Share on other sites

hi,

If battery is weak can i run the car in that condition or it will create a problem in ECU or any other parts in the engine because i think that i can use that battery for  6 month and i will change please reply.

Share this post


Link to post
Share on other sites

Two things:

You can get the replacement battery far cheaper outside. No need to go to a mass.

For the past decade in our family we are only buying Amaron once the OE gives up the ghost.

No real harm in running with a battery on the death bed. It is  pain and best avoided.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...