sham

noise after i changed my tire, Urgent help please

Recommended Posts

Hi all,

After not being able to figure out why my left front tire was losing air faster than the rest, I decided to swap it with the spare and see what happens.

2 days ago i swapped the tire and ever since then, I'm hearing a "Tak" "Tak" noise from the left front.

Its like a stone is constantly hitting the under-chasis.

I'm not sure what mistake i did but there is no wobbling sensation. The drive feel is the same and Everthing is as it should be except for this noise.

I'm taking the car out for a check up tomorrow so before that if anyone can give me a heads up on what to look for or ask i would be grateful.

Thank you.

Share this post


Link to post
Share on other sites

Thank you guys for the response.

I was in for a shock when i took the car to the service station.

One of the bolts had come loose, I remember tightening every single bolt , I guess i did a sloppy job. Thankfully I didnt drive much after the noise started to occur and now its fixed.

Thank you all

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...